RADPayor Issues

Incident Report for Bay Medical IT Services Status

Resolved

RADPayor access has been restored and staff are now able to access the application internally as needed.
Posted Jun 27, 2024 - 10:15 PDT

Identified

Users are currently experiencing connection issues with RADpayor internally. Bay Medical ITS have identified the issue and are working with our vendors to correct the connection.
Posted Jun 27, 2024 - 08:36 PDT